Z11 heater issues
  • Hi all.

    A while back I had a chat with someone on the facebook group about cold heaters. Their problem was solved by flushing out the heater matrix with some radiator flushing liquid. 

    I have just returned from halfords with a bottle of this liquid and I'm hoping someone here will be able to advise me on the most effective way to do this. I'd rather not have to pull the dash apart and physically remove the matrix unless it's the only way.
  • If you look on youtube thee is a few general how to vids on there
  • Lol yes there are. Easy job :)
  • I've flushed the core now, got good flow through it but my heaters are still cold! I've had the side of the dash off and from what I can tell everything is working. When I fiddle with the temperature controls things move around so I'm stuck >.<
  • Update
    Pulled the glove box, centre console and a load of other stuff to access the cogs and things on the left side of the heater controls. One plastic component attached to the side rotates when I turn the heater up. I thought it looked a little loose, gave it a poke and it fell straight off. Right, I'm getting somewhere. See pic. I'm pointing at it with a screwdriver.

    Whatever it was attached to can be rotated 90 degrees with a screwdriver. Must be opening the hot/cold valve.

    I drilled a hole down the middle, turned the heater to cold, covered a 1 inch screw in araldite (awesome glue) and screwed it back on. Once the glue dries I'll know if this worked.

    Now we play the waiting game.



    image.jpg
    2448 x 3264 - 1M
  • Still nothing. I give up. Just installed some awesome ebay heated seat kits.

    I'll be back on this once it starts getting colder again.