Accelerator pedal
  • Which other Nissan has the same accelerator pedal as a Gen 2 Cube. I'm guessing Juke??
  • More likely k12 Micra or nissan note.

    The juke came later, in line with the gen 3 z12 cube.
  • Cheers. I'll be doing the rounds in the scrapyards in the next few days.
  • juke is likely to match the GEn 3 as they share other poarts but so does the gen 3 and Note..
  • I managed to get one in the scrap yards this week. I was delighted to hear in the first scrapyard that he didn't have one because they give trouble. It means that the pedal is fairly likely to be the problem.

    I got one in the next scrapyard from a Micra (actually a March) and have it fitted to the car already. It's just three bolts. I'm now waiting on the problem to happen again.

    I paid 50euro :(

  • The new pedal didn't fix the problem. Back to the scrap yard for the receiver.
  • So what is the problem you're getting?
  • The engine light comes on and the car goes into limp mode. It clears when you switch it off and back on again. It only happens about twice a month in the mornings mainly after the car has been running for 10 mins. I initially thought it was related to the automatic choke. I've put a diagnostic tool on the engine and got a P1122 error. This is related to the accelerator actuator. Electric throttle control function does not operate properly.

    I've replaced the pedal end now I have to get the reciever at the engine side.

  • This problem seems to have sorted itself out. It may be down to the lack of wet weather? I have been actuating the pedal before starting the engine to "free" stuff up a bit. It may be caused by the fact that the pedal doesn't get as much action as it would if the car were manual.

    All I can do now is wait for the damp weather to come back. As I'm in Ireland it should be any day now.

  • Well the problem came back. It never happens in the summer only in winter. It was happening about 3 time on average each journey. Up till now it was once a day. I was able to get the throttle body (butterfly valve) at my local scrap yard. It only takes 15 mins to replace. It looks like the problem is gone.
  • Have you tried re calibrating the throttle?