2004 nissan cube gearbox problem maybe ??
  • I HAVE A 2004 NISSAN CUBE 7 SEATER WITH A 1.4 CVT   , JUST HAD A SECONDHAND GEARBOX FITTED WHICH WAS RUNNING FINE FOR ABOUT A MONTH  , FIRST SYMTOMS WAS PULLED AWAY FROM LIGHTS FIRST GEAR WAS FINE DIDNT WANT TO GO INTO SECOND UNTIL I DROP REVS DOWN  , THEN TWO WEEKS LATER STARTED TO DO THIS MORE FREQANT , BUT NOW IM GETTING LOSS OF ENGINE POWER WITH SHUDDERING AND FEELS LIKE IM DRIVING WITH A FLAT TYRE  ,  IVE CHECKED THE FLUID IN GEARBOX AND ALL SEEMS OK BUT I SPOKE TO GARAGE AND THEY RECKON IT WILL NEED FLUSHING OUT AND NEW FLUID PUT  IN ,  HAS ANYONE HAD ANY OF THESE PROBLEMS  , I THINK IT COULD BE A SENSOR?
  • Hi not shaw but if was a sensor it should be able to be code read. as for flushing not so shaw. Code read engine and gearbox first .may be a lose connection
  • Hi. Any news here? Sounds like something familiar, I just got my Cube today, everything was fine but it did this: " LOSS OF ENGINE POWER WITH SHUDDERING AND FEELS LIKE IM DRIVING WITH A FLAT TYRE" only one difference is that I cant really drive, only re-park and move on driveway...
  • Any update on this?

    Mine is doing this -

    FIRST SYMTOMS WAS PULLED AWAY FROM LIGHTS FIRST GEAR WAS FINE DIDNT WANT TO GO INTO SECOND UNTIL I DROP REVS DOWN 

    And I have to force the lever up to R / P from D.

    I'm going to check fluid level and plug it into my diagnostics tonight. :(

  • mine turned out to be passenger side brake caliper was seized  , messing up revs for the gearbox to work properly  , fixed that everything was fine    2months later  i have no 4th gear  overdrive button dont work but lights up      any help please
  • i have a spare cvt gearbox for sale  as it was leaking fluid  had it changed with a recon gearbox , the old gearbox worked fine and it only needs a simple seal on torque converter which i was told by the garage which costs about 15 quid but didnt know this at the time 
  • My CVT problems turned out to be caused by me!

    I fitted a new, bigger battery last week and whilst driving it had slipped into the path of the CVT actuator.

    When I tested my gear oil level last night I noticed a grazing if plastic battery case and realised my error.

    Bought a new battery clamp today to fix it in more securely and hey presto all was sorted. :D

  • Race on again then ..... see if you got more beef lol we gonna meet up on convoy .
  • I'm not sure it's up to your acceleration yet ;)
  • Simon, what you got going on under the bonnet? I noticed your Cube seemed a little livelier than an average one before Japfest! :)