over heating toaster
  • i notice this last week before my car had some work done was driving up to my mums and the water light came on in red.
    got to my mums looked to see some water spray in some places so i let it cool down and toped up the water to see if there was any leaks nothing. i went home red light was off.

    so a week 2 weeks later today driving the cube the red light came on i pulled over this time no spray but the pipe going from the radiator to the engine was making a noise like the water was rushing and stooping like boiling water.

    so does this sound like the water pump has gone ?
  • You have a leak ? and the water level is too low ? thus making it overheat ?
    ofcourse it can be the waterpump too.
  • Thats the thing no water leaking and water is full so im thinking the water pump
  • Sounds a bit like what was happening to mine, turned out the head gasket was blowing a little and pushing air into the cooling system which then air locked and over heated. Good luck getting it sorted.
  • Could be both, now....

    pump gone bad, and then overheating, then ruining your headgasket?

    Belt not slipping ?
  • Belt is fine going to get looked at after work
  • Not sure if they even have it but, thermostat if its stuck open/closed it wont even let the water into your radiator....hth
  • I had a problem with my first cube where the green relay / fuse under the bonnet which is for the radiator fan had popped so the radiator fan stopped turning on and causing overheating.

    I got a new relay/fuse type block thing from Nissan and it sorted it. (Same as a K12)

    It's a green L shaped block in the black horizontal plastic box at the front right of the engine bay, in front of the battery. Pop the lid off and check to see if one of the metal bars has snapped.

    I'll try and find my thread from the time...
  • Here's my thread - http://forum.cubeownersclub.co.uk/topic/636#post-3818

    You'll have to look closely if it is this as you can't tell from the photo that it has gone but there was a hairline crack in the metal bridge.

    Hopefully it's just this. :)
  • ok just now i let the cube run idle for a bit so i can see whats going on fan came on about 4 mins in then 2 mins later it went faster then 2 mins after that the water started to come out of the coolant tank which was the only leak

    now im thinking can it be the water pump or the thermostat what you lot think ?
  • Check for gunk under oil filler cap?
  • Turns out it was the thermostat. i might post a how to.vid to kick off my youtube channle
  • mine also overheated last time...change thermostate which cost cheap....solved the problem.

    shymz_2000@yahoo.com
    www.kenyalang.net
  • Hiya Ive just posted this issue on FB and forgot to look here!

    Garage wants to charge me £140 for new thermostat as they say micra one doesnt work on 2nd generation. Think im being taken for a ride! 
  • I bought one from a main dealer recently. Fitted myself in 10 minutes £22.00. Works fine.
  • Was that the micra one you used?
  • Please send me a postcard when you take the ride as its a good one . No way in a garage part plus hour labour + anti freeze £60/80 tops. if you now how diy even cheaper .
  • It was the seals that failed on my unit letting in air with a tiny coolant leak. It was not necessarily the unit failing to operate.

    I asked for unit to fit a CR14DE engine Micra K12. The answer was that it might have a different operating temperature to a cube. I looked at the one fitted to my cube and it looks exactly the same. But then I have no idea if the previous owner had the correct part fitted in the first place.